Wymagania

Aby korzystać z funkcji readline niezbędne jest zainstalowanie biblioteki libreadline. Bibliotekę libreadline można znaleźć na witrynie projektu GNU Readline, » http://cnswww.cns.cwru.edu/~chet/readline/rltop.html Jest ona rozwijana przez Cheta Ramey'a, który jest także autorem Basha.

Z tych funkcji można skorzystać także przy użyciu biblioteki libedit, zamiennika biblioteki readline, wydanego na licencji innej niż GPL. Biblioteka libedit jest wydana na licencji BSD i można ją znaleźć pod adresem » http://www.thrysoee.dk/editline/.

add a note add a note

User Contributed Notes 1 note

up
-1
Anonymous
9 years ago
Note that libedit does not support the function readline_list_history()
To Top