PHP Australia Conference 2015

Pré-requis

Vous devez installer d'abord la bibliothèque librrd afin d'utiliser l'extension PECL/rrd. Vérifiez si votre distribution favorite Linux propose le paquet librrd-dev. PECL/rrd est testé avec librrd 1.4.3, les anciennes versions ou les plus récentes peuvent ou non fonctionner. L'installation PECL/rrd est testé avec PHP 5.3.2 ou suivants.

Avertissement

Librrd et donc l'extension elle-même ne sont pas, la plupart du temps, thread safe. Il y a beaucoup d'états globaux et partagés dans librrd. Ce peut être dangereux d'utiliser cette extension en environnement multi-thread comme Apache 2 mpm worker. S'il y a plusieurs requêtes parallèles, une d'entre elles peut modifier l'état global de la bibliothèque librrd, affectant ainsi les autres requêtes en cours d'exécution.

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top