PHP 5.5.17 is available

Modifications entrainant une incompatibilité ascendante

Bien que la plupart du code PHP 5 existant devrait fonctionner sans aucune modification, vous devez prendre en considération quelques incompatibilités ascendantes :

Abandon du support de Windows XP et 2003

Le support de Windows XP et 2003 a été supprimé. Les binaires Windows de PHP requièrent maintenant Windows Vista ou supérieur.

La sensibilité à la casse ne dépend plus de la locale utilisée

Toutes les comparaisons insensibles à la casse pour les noms de fonctions, de classes, et de constantes sont maintenant indépendantes de la locale utilisée, et respectent les règles ASCII. Ceci permet une meilleure prise en charge des langues utilisant l'alphabet latin avec des règles d'assemblage inhabituelles, comme le turc et l'azerbaïdjan.

Ceci peut avoir des impacts sur le code qui utilise l'insensibilité à la casse pour des caractères non-ASCII avec des jeux de caractères multi-octets (incluant l'UTF-8), comme les caractères accentués pour de nombreuses langues européennes. Si vous avez du code basé sur des langues non-anglaises, et non-ASCII, alors vous devriez tester que vous n'êtes pas impacté par ce changement de comportement avant de déployer PHP 5.5 en environnement de production.

Modifications des fonctions pack() et unpack()

Des modifications ont été réalisées sur les fonctions pack() et unpack() pour les rendre plus compatible avec Perl :

  • pack() supporte maintenant le code format "Z", dont le comportement est identique à "a".
  • unpack() supporte maintenant le code format "Z" pour les chaînes de caractères complétées avec la valeur NULL, et se comporte comme "a" dans les précédentes versions : il va supprimer les octets NULL finaux.
  • unpack() conserve maintenant les octets NULL finaux lorsque le code format "a" est utilisé.
  • unpack() supprime maintenant les espaces blancs ASCII finaux lorsque le code format "A" est utilisé.

L'écriture de code compatible de façon ascendante qui utilise le code format "a" avec la fonction unpack() requiert l'utilisation de la fonction version_compare(), en raison de cette cassure de compatiblité ascendante.

Par exemple :

<?php
// Ancien code :
$data unpack('a5'$packed);

// Nouveau code :
if (version_compare(PHP_VERSION'5.5.0-dev''>=')) {
  
$data unpack('Z5'$packed);
} else {
  
$data unpack('a5'$packed);
}
?>

self, parent et static sont maintenant insensible à la casse

Avant PHP 5.5, des cas existaient où les mots clés self, parent et static étaient traités de façon sensible à la casse. Ceci a maintenant été résolu, et ces mots clés sont toujours gérés de façon insensible à la casse : SELF::CONSTANT est maintenant traité exactement comme self::CONSTANT.

Suppression des logos PHP GUIDs

Les GUIDs qui permettaient précédemment l'affichage de divers logos PHP ont été supprimés. Ceci inclut la suppression des fonctions qui retournaient ces GUIDs. Voici une liste des fonctions supprimées :

Modification dans l'exécution interne

Les auteurs d'extensions devraient noter que la fonction zend_execute() ne peut plus être surchargée, et que de nombreux changements ont été effectués sur la structure execute_data ainsi que sur les fonctions associées et sur les opcodes de gestion de méthodes.

La plupart des extensions ne sont normalement pas affectées par ces modifications, mais celles profondément ancrées dans le moteur Zend le seront, et nous recommandons à leurs auteurs de lire les notes relatives à ces modifications.

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top