Nouvelles constantes globales

Coeur de sPHP :

  • __DIR__
  • __NAMESPACE__
  • E_DEPRECATED
  • E_USER_DEPRECATED
  • INI_SCANNER_NORMAL
  • INI_SCANNER_RAW
  • PHP_MAXPATHLEN
  • PHP_WINDOWS_NT_DOMAIN_CONTROLLER
  • PHP_WINDOWS_NT_SERVER
  • PHP_WINDOWS_NT_WORKSTATION
  • PHP_WINDOWS_VERSION_BUILD
  • PHP_WINDOWS_VERSION_MAJOR
  • PHP_WINDOWS_VERSION_MINOR
  • PHP_WINDOWS_VERSION_PLATFORM
  • PHP_WINDOWS_VERSION_PRODUCTTYPE
  • PHP_WINDOWS_VERSION_SP_MAJOR
  • PHP_WINDOWS_VERSION_SP_MINOR
  • PHP_WINDOWS_VERSION_SUITEMASK

cURL:

  • CURLOPT_PROGRESSFUNCTION

GD :

  • IMG_FILTER_PIXELATE

JSON :

  • JSON_ERROR_CTRL_CHAR
  • JSON_ERROR_DEPTH
  • JSON_ERROR_NONE
  • JSON_ERROR_STATE_MISMATCH
  • JSON_ERROR_SYNTAX
  • JSON_FORCE_OBJECT
  • JSON_HEX_TAG
  • JSON_HEX_AMP
  • JSON_HEX_APOS
  • JSON_HEX_QUOT

LDAP :

  • LDAP_OPT_NETWORK_TIMEOUT

libxml:

  • LIBXML_LOADED_VERSION

PCRE :

  • PREG_BAD_UTF8_OFFSET_ERROR

PCNTL :

  • BUS_ADRALN
  • BUS_ADRERR
  • BUS_OBJERR
  • CLD_CONTIUNED
  • CLD_DUMPED
  • CLD_EXITED
  • CLD_KILLED
  • CLD_STOPPED
  • CLD_TRAPPED
  • FPE_FLTDIV
  • FPE_FLTINV
  • FPE_FLTOVF
  • FPE_FLTRES
  • FPE_FLTSUB
  • FPE_FLTUND
  • FPE_INTDIV
  • FPE_INTOVF
  • ILL_BADSTK
  • ILL_COPROC
  • ILL_ILLADR
  • ILL_ILLOPC
  • ILL_ILLOPN
  • ILL_ILLTRP
  • ILL_PRVOPC
  • ILL_PRVREG
  • POLL_ERR
  • POLL_HUP
  • POLL_IN
  • POLL_MSG
  • POLL_OUT
  • POLL_PRI
  • SEGV_ACCERR
  • SEGV_MAPERR
  • SI_ASYNCIO
  • SI_KERNEL
  • SI_MESGQ
  • SI_NOINFO
  • SI_QUEUE
  • SI_SIGIO
  • SI_TIMER
  • SI_TKILL
  • SI_USER
  • SIG_BLOCK
  • SIG_SETMASK
  • SIG_UNBLOCK
  • TRAP_BRKPT
  • TRAP_TRACE
add a note add a note

User Contributed Notes 2 notes

up
1
webmozart
1 year ago
For someone that is looking for the possible values of PHP_WINDOWS_VERSION_MAJOR and PHP_WINDOWS_VERSION_MINOR (like I was), see here:
http://msdn.microsoft.com/en-us/library/windows/desktop/ms724832.aspx
up
0
mlocati
5 months ago
For these PHP versions:
- PHP 5.3
- PHP 5.4
- PHP 5.5 up to 5.5.26 (included)
- PHP 5.6 up to 5.6.10 (included)

the value of
<?php
PHP_WINDOWS_VERSION_MAJOR
. '. ' . PHP_WINDOWS_VERSION_MINOR . '. ' . PHP_WINDOWS_VERSION_BUILD;
?>
is limited to 6.2.9200 (Windows 8) even if the OS is newer (Windows 8.1, Windows 10).

The reason of this problem is this change in the Windows API:
https://msdn.microsoft.com/en-us/library/windows/desktop/dn302074(v=vs.85).aspx

A fix for this has been added to PHP 5.5 from 5.5.27, and PHP 5.6 from 5.6.11 (and all versions of PHP 7 are ok).

For more details about this, see https://github.com/symfony/symfony/pull/18385#issuecomment-204406795
To Top