PHP Unconference Europe 2015

Requerimientos

Phar requiere PHP 5.2.0 o superior. Las caracteristicas adicionales requieren la extensión SPL para aprovechar la iteración y el acceso a arrays del contenido de un fichero de Phar. El flujo phar no requiere ninguna extensión adicional para que funcione.

Opcionalmente, se puede habilitar las extensiones zlib y bzip2 para aprovechar el soporte de phar comprimidos. Además, para aprovechar la firma OpenSSL, debe estar habilidata la extensión OpenSSL.

Observe que un error en el filtro de flujos zlib.deflate corregido en la versión 5.2.6 y posteriores de PHP puede ocasionar el truncamiento de archivos phar comprimidos con gzip bzip2.

PHP 5.3 configurado con --enable-zend-multibyte hace que phar dependa de la opción ini detect_unicode.

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top