PHP 5.6.24 is released

Características obsoletas en PHP 5.5.x

Obsolescencia de ext/mysql

La extensión de MySQL original ahora está obsoleta, generando errores de nivel E_DEPRECATED al conectarse a una base de datos. Emplee en su lugar las extensiones MySQLi o PDO_MySQL.

Modificador /e de preg_replace()

El modificador /e de preg_replace() ahora está obsoleto. Emplee en su lugar la función preg_replace_callback().

Obsolescencias de intl

IntlDateFormatter::setTimeZoneID() y datefmt_set_timezone_id() ahora están obsoletas. Emplee en su lugar el método IntlDateFormatter::setTimeZone() y la función datefmt_set_timezone() respectivamente.

Obsolescencias de mcrypt

Las siguientes funciones están obsoletas:

add a note add a note

User Contributed Notes 1 note

up
-2
Gianluca
4 months ago
In these wrappers all mysql and ereg functions are rewritten using mysqli and pcre
https://sourceforge.net/projects/mysqlwithmysqli/
https://sourceforge.net/projects/ereg-using-pcre/
To Top