PHP Unconference Europe 2015

Migración de PHP 4 a PHP 5

Esta sección de la FAQ lo ayudará a migrar de PHP 4 a PHP 5.

Migración de PHP 4 a PHP 5

A pesar de que PHP 5 ofrece muchas características nuevas, fue diseñado para ser tan compatible como fuese posible con versiones anteriores con pequeñas funcionalidades arruinadas en el proceso.

Asegúrese de leer el apropiado Apéndice de migración a PHP 5 de este manual ya que contiene aún más información en el tema de migrar a PHP 5.

¿MySQL funciona con PHP 5? Pareciera que ya no.

MySQL es soportado con la única diferencia que dicho soporte ya no está habilitado por defecto en PHP 5. Esto esencialmente significa que PHP no incluye la opción --with-mysql en la línea configure para que se deba agregar manualmente a la hora de compilar PHP. Los usuarios de Windows tendrán que editar php.ini y habilitar la DLL php_mysql.dll. En PHP 4 esa DLL no existía, sino que simplemente estaba incorporada en los binarios de PHP para Windows.

También, las bibliotecas de cliente MySQL ya no están incluidas con PHP. Más detalles sobre este tema son desarrollados en la siguiente FAQ y asegúrese de leer la sección de MySQL para detalles sobre la instalación de MySQL. Un ejemplo de línea configure sería --with-mysql=/usr mientras que usuarios de Windows necesitarán tener disponible libmySQL.dll

He oído que PHP 5 tiene un modelo OOP totalmente renovado, ¿Mi código OOP existente seguirá funcionando? ¿Dónde encuentro información sobre las nuevas características del modelo OOP?

El principal cambio en PHP 5 es el modelo OOP ya que PHP 5 ahora utiliza el Zend Engine 2.0. La directiva zend.ze1_compatibility_mode habilita compatibilidad con el Zend Engine 1.0 (PHP 4).

El nuevo modelo OOP está documentado en las secciones Referencia del lenguaje - OOP y Apéndice de migración - OOP.

Entonces, además del nuevo modelo OOP, ¿Qué más cambió en PHP 5? ¿También hay una versión específica del manual correspondiente a PHP 5?

Existen otros pocos cambios, vea el Apéndice de migración a PHP 5 para detalles. No habrá una versión específica del manual correspondiente a PHP 5 puesto que mayoritariamente PHP permanece igual.

add a note add a note

User Contributed Notes 2 notes

up
0
gfrank at neoservers dot com
7 years ago
To get PHP5 and PHP4 to work at the same time you will also need to change all "php_value", "php_flag", "php_admin_flag", and "php_admin_value" occurences; otherwise, you can't set configuration file settings.
up
-3
odnowa-sql at o2 dot no-spam pl
7 years ago
You can run PHP4 and PHP5 as Apache2 modules at the same time. The trick is to hack the sources a little bit.
Change all occurences of application/x-httpd-php (and MIME type for sources) to application/x-httpd-php5 and then add that mime type to apache conf.
To Top