SunshinePHP Developer Conference 2015

Instalación

Usando la opción de configuración --enable-dba=shared se puede construir un módulo cargable dinámico para habilitar PHP para el soporte básico de bases de datos estilo dbm. También se tiene que añadir soporte para al menos uno de los siguientes gestores especificando el conmutador --with-XXXX de configure a la línea de configuración de PHP.

Advertencia

Después de configurar y compilar PHP debe ejecutar la siguiente prueba desde la línea de comandos: php run-tests.php ext/dba. Esto muestra si la combinación de gestores funciona. Los más problemáticos son dbm y ndbm ya que entran en conflicto con muchas instalaciones. La razón de esto es que en muchos sistemas estas bibliotecas son parte de más de una biblioteca. La prueba de configuración sólo previene del malfuncionamiento de configuración de gestores únicos, pero no de combinaciones.

Gestores de DBA soportados
Gestor Conmuntador de Configuración
dbm

Para habilitar el soporte para dbm añada --with-dbm[=DIR] .

Nota:

dbm es normalmente una envoltura que a menudo resulta en fallo. Esto significa que debería usar dbm sólo si está seguro de que funciona y que realmente necesita este formato.

ndbm

Para habilitar el soporte para ndbm añada --with-ndbm[=DIR] .

Nota:

ndbm es normalmente una envoltura que a menudo resulta en fallo. Esto significa que debería usar ndbm sólo si está seguro de que funciona y que realmente necesita este formato.

gdbm Para habilitar el soporte para gdbm añada --with-gdbm[=DIR] .
db2

Para habilitar el soporte para Oracle Berkeley DB 2 añada --with-db2[=DIR] .

Nota:

db2 entra en conflicto con db3 y db4.

db3

Para habilitar el soporte para Oracle Berkeley DB 3 añada --with-db3[=DIR] .

Nota:

db3 entra en conflicto con db2 y db4.

db4

Para habilitar el soporte para Oracle Berkeley DB 4 o 5 añada --with-db4[=DIR] .

Nota:

db4 entra en conflicto con db3 y db3.

Nota:

La opción db4 se añadió en PHP 4.3.2. En versiones anteriores de PHP se necesita usar --with-db3=DIR , siendo DIR la ruta a la biblioteca db4. No es posible usar versiones de db de 4.1 en adelante con PHP anterior a la versión 4.3.0. También, las bibliotecas db con versiones 4.1 hasta 4.1.24 no se pueden usar en ninguna versión de PHP.

Se añadión el soporte para BDB 5 en PHP 5.3.3.

cdb

Para habilitar el soporte para cdb añada --with-cdb[=DIR] .

Nota:

Desde PHP 4.3.0 se puede omitir DIR para usar la biblioteca cdb incluida que añade el gestor cdb_make, el cual permite la creación de ficheros cdb y el acceso a ficheros cdb en la red usando flujos de PHP.

flatfile

Para habilitar el soporte para flatfile añada --with-flatfile .

Nota:

Esto se añadio en PHP 4.3.0 para añadir compatibilidad con la extensión dbm obsoleta. Use este gestor solamente cuando no pueda instalar una de las bibliotecas requeridas por otros gestores y cuando no pueda usar el gestor cdb interno.

inifile

Para habilitar el soporte para inifile añada --with-inifile .

Nota:

Esto se añadió en PHP 5.0.0 y permite leer y establecer ficheros .ini estilo microsoft (como el fichero php.ini).

qdbm

Para habilitar el soporte para qdbm añada --with-qdbm[=DIR] .

Nota:

qdbm entra en conflicto con dbm y gdbm.

Nota:

Esto se añadió en PHP 5.0.0. La biblioteca qdbm puede ser cargada desde » http://fallabs.com/qdbm/index.html.

Nota:

Hasta PHP 4.3.0 se puede añadir el gestor db2 y db3 pero sólo uno de ellos se puede usar internamente. Esto significa que no se pueden tener ambos formatos de fichero. Desde PHP 5.0.0 existe una comprobación de configuración que evita tales configuraciones erróneas.

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top