PHP Unconference Europe 2015

Installation

This » PECL extension is not bundled with PHP.

Information for installing this PECL extension may be found in the manual chapter titled Installation of PECL extensions. Additional information such as new releases, downloads, source files, maintainer information, and a CHANGELOG, can be located here: » http://pecl.php.net/package/SPL_Types.

A DLL for this PECL extension is currently unavailable. See also the building on Windows section.

add a note add a note

User Contributed Notes 2 notes

up
0
symfonist at gmail dot com
10 months ago
You should install dev version of libpcre3:

sudo apt-get install libpcre3-dev.

Make sure php5-dev is installed.

sudo apt-get install php5-dev
up
0
Jayesh Wadhwani
1 year ago
I did run into one problem while installing this extension on 5.5.3, Ubuntu 12.04, and that was the missing libpcre3. Once I installed the lib the install went fine.

sudo apt-get install libpcre3

sudo pecl install SPL_Types
To Top