Forum PHP 2017

Installation

Die hier beschriebenen Socket-Funktionen sind Teil einer PHP-Extension, die zum Zeitpunkt des Kompilierens eingeschaltet sein muss. Verwenden Sie dazu die Option --enable-sockets des configure-Kommandos.

Hinweis: IPv6-Unterst├╝tzung steht seit PHP 5.0.0 zur Verf├╝gung.

add a note add a note

User Contributed Notes 1 note

up
-30
seb at stiaan dot io
4 months ago
At the time of writing, most Linux distributions ship their PHP versions with sockets enabled by default.
Tested distros/versions:

CentOS 7, PHP 5.4: Enabled;
CentOS 7, Remi repo, PHP 7.1.1: Enabled;
CentOS 7, DirectAdmin Custombuild, PHP 7.0.9: Enabled;
CentOS 7, DirectAdmin Custombuild, PHP 5.6.24: Enabled;
Debian Jessie, PHP 5.6.30-0+deb8u1: Enabled;
Gentoo Linux ~amd64, PHP 7.1.1: Enabled (USE-flag "sockets" is enabled by default)

Alpine Linux: PHP 5.6.30: Disabled, however this can simply be enabled by installing php5-sockets

I haven't tested other distros/versions, but as far as compatibility goes most systems seem to support sockets out of the box.
To Top