Last 5.3 release ever available: PHP 5.3.29 - 5.3 now EOL

Installation/Konfiguration

Inhaltsverzeichnis

add a note add a note

User Contributed Notes 4 notes

up
6
dtrebbien at gmail dot com
3 years ago
Debian Squeeze users can install the intl extension with:

sudo apt-get install php5-intl
up
1
hans
4 years ago
2 Thinks what helped me.

1. test if it works with on command line "php -i | grep intl"
if it's not correctly installed and doesn't work it will show nothing.
2. I created the file /etc/php5/conf.d/intl.ini and only put the line extension=intl.so in that file (restart apache and done)
up
1
s dot marechal at jejik dot com
6 years ago
I have written a simple tutorial on how you can install the intl extension for PHP5 on Debian Lenny. It probably also works on anything derived from it, such as the recent Ubuntus or Linux Mint. You can find it at:

http://www.jejik.com/articles/2008/07/howto_build_and_install_the_intl_pecl_extension_for_php5_in_debian/

(This URL should be on one line of course)
up
0
dtrebbien at gmail dot com
4 years ago
To install the intl extension on a Debian Lenny system, the following commands (as `root`) worked perfectly for me:
apt-get install php-pear php5-dev dh-make-php fakeroot libicu38 libicu-dev xsltproc
pear channel-update pear.php.net
pear upgrade PEAR
pecl channel-update pecl.php.net
pear install intl

Probably the first line can be replaced with just:
apt-get install php-pear php5-dev libicu38 libicu-dev

But, you may need some of the other packages.
To Top